Commit bc30f23d authored by Jan Möbius's avatar Jan Möbius

Dont build GUI apps with mingw for now. Incompatible linking with opengl


git-svn-id: http://www.openmesh.org/svnrepo/OpenMesh/trunk@472 fdac6126-5c0c-442c-9429-916003d36597
parent 214bc1f2
......@@ -44,15 +44,21 @@ endif ()
# check for OpenGL and GLUT as our required dependencies
if (QT4_FOUND AND OPENGL_FOUND AND GLUT_FOUND )
if (QT4_FOUND AND OPENGL_FOUND AND GLUT_FOUND AND NOT "${CMAKE_GENERATOR}" MATCHES "MinGW Makefiles" )
add_subdirectory (Decimating/DecimaterGui)
add_subdirectory (QtViewer)
add_subdirectory (Subdivider/SubdividerGui)
add_subdirectory (ProgViewer)
add_subdirectory (VDProgMesh/Synthesizer)
# Add ui apps as dependency before fixbundle
if ( WIN32 AND NOT "${CMAKE_GENERATOR}" MATCHES "MinGW Makefiles")
# let bundle generation depend on all targets
add_dependencies (fixbundle DecimaterGui ProgViewer QtViewer SubdividerGui Synthesizer)
endif()
# Add ui apps as dependency before fixbundle
if ( WIN32 OR APPLE)
if ( APPLE)
# let bundle generation depend on all targets
add_dependencies (fixbundle DecimaterGui ProgViewer QtViewer SubdividerGui Synthesizer)
endif()
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment