Commit 684f3f70 authored by Jan Möbius's avatar Jan Möbius

Removed check for Qt less than 5

parent daebbce7
......@@ -49,11 +49,7 @@
#include <ui_addAnimation.hh>
#if QT_VERSION >= 0x050000
#include <QtWidgets>
#else
#include <QtGui>
#endif
class AddAnimationDialog : public QDialog, public Ui::AddAnimation
......
......@@ -49,11 +49,7 @@
#include <ui_animationControls.hh>
#if QT_VERSION >= 0x050000
#include <QtWidgets>
#else
#include <QtGui>
#endif
class AnimationToolboxWidget : public QWidget, public Ui::AnimationControls
......
......@@ -1073,8 +1073,5 @@ void SkeletalAnimationPlugin::setComboBoxPosition(unsigned int _animationIndex)
//------------------------------------------------------------------------------
#if QT_VERSION < 0x050000
Q_EXPORT_PLUGIN2(skeletalAnimationplugin, SkeletalAnimationPlugin);
#endif
......@@ -78,9 +78,7 @@ class SkeletalAnimationPlugin : public QObject, BaseInterface, ToolboxInterface,
Q_INTERFACES(LoadSaveInterface)
Q_INTERFACES(RPCInterface)
#if QT_VERSION >= 0x050000
Q_PLUGIN_METADATA(IID "org.OpenFlipper.Plugins.Plugin-SkeletalAnimation")
#endif
private:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment