Commit c8ae1a91 authored by Isaak Lim's avatar Isaak Lim

added a Qwt6 finder, which is required for QT5 and adjusted plugins accordingly

refs #1753

git-svn-id: http://www.openflipper.org/svnrepo/OpenFlipper/branches/Free@17639 383ad7c9-94d9-4d36-a494-682f7c89f535
parent 6d856c2d
include(plugin)
find_package(Qwt5)
# use Qwt6 for QT5
if (NOT FORCE_QT4 AND QT5_FOUND)
find_package(Qwt6)
if(Qwt5_Qt4_FOUND)
add_definitions(-DWITH_QWT)
openflipper_plugin(INCDIRS ${Qwt5_INCLUDE_DIR}
LIBRARIES ${Qwt5_Qt4_LIBRARY}
INSTALLDATA Icons
)
if (QWT6_FOUND)
add_definitions(-DWITH_QWT)
openflipper_plugin(INCDIRS ${QWT6_INCLUDE_DIRS}
LIBRARIES ${QWT6_LIBRARIES}
INSTALLDATA Icons
)
else()
openflipper_plugin(INSTALLDATA Icons)
endif()
else()
openflipper_plugin(INSTALLDATA Icons)
find_package(Qwt5)
if(Qwt5_Qt4_FOUND)
add_definitions(-DWITH_QWT)
openflipper_plugin(INCDIRS ${Qwt5_INCLUDE_DIR}
LIBRARIES ${Qwt5_Qt4_LIBRARY}
INSTALLDATA Icons
)
else()
openflipper_plugin(INSTALLDATA Icons)
endif()
endif()
......@@ -78,6 +78,8 @@
#include <ACG/QtWidgets/QwtHistogramm.hh>
#include <vector>
#include <QDialog>
//== FORWARDDECLARATIONS ======================================================
//== NAMESPACES ===============================================================
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment