Commit eb696852 authored by Jan Möbius's avatar Jan Möbius

Removed check for Qt less than 5

parent 94ae51b4
......@@ -50,11 +50,7 @@
#include "FileSTL.hh"
#if QT_VERSION >= 0x050000
#include <QtWidgets>
#else
#include <QtGui>
#endif
/// Constructor
FileSTLPlugin::FileSTLPlugin() :
......@@ -324,8 +320,5 @@ void FileSTLPlugin::slotLoadDefault() {
void FileSTLPlugin::slotSaveDefault() {
OpenFlipperSettings().setValue( "FileSTL/Save/Binary", saveBinary_->isChecked() );
}
#if QT_VERSION < 0x050000
Q_EXPORT_PLUGIN2( filestlplugin , FileSTLPlugin );
#endif
......@@ -77,9 +77,7 @@ class FileSTLPlugin : public QObject, BaseInterface, FileInterface, LoadSaveInte
Q_INTERFACES(BaseInterface)
Q_INTERFACES(ScriptInterface)
#if QT_VERSION >= 0x050000
Q_PLUGIN_METADATA(IID "org.OpenFlipper.Plugins.Plugin-FileSTL")
#endif
signals:
void openedFile( int _id );
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment