Commit b67ddb23 authored by Jan Möbius's avatar Jan Möbius

Removed check for Qt less than 5

parent 7184bec5
......@@ -52,11 +52,7 @@
#include <OpenFlipper/BasePlugin/PluginFunctions.hh>
#include <OpenFlipper/common/GlobalOptions.hh>
#if QT_VERSION >= 0x050000
#include <QtWidgets>
#else
#include <QtGui>
#endif
void FileSPHPlugin::initializePlugin() {
......@@ -190,8 +186,5 @@ bool FileSPHPlugin::saveObject(int _id, QString _filename)
return true;
}
#if QT_VERSION < 0x050000
Q_EXPORT_PLUGIN2( filesphplugin , FileSPHPlugin );
#endif
......@@ -69,9 +69,7 @@ class FileSPHPlugin : public QObject, BaseInterface, FileInterface, LoadSaveInte
Q_INTERFACES(BaseInterface)
Q_INTERFACES(ScriptInterface)
#if QT_VERSION >= 0x050000
Q_PLUGIN_METADATA(IID "org.OpenFlipper.Plugins.Plugin-FileSPH")
#endif
signals:
void openedFile( int _id );
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment