Commit b0cf2762 authored by Jan Möbius's avatar Jan Möbius

Fixed ObjectUpdated function where old version was used, when both are available!

git-svn-id: http://www.openflipper.org/svnrepo/OpenFlipper/branches/Free@9089 383ad7c9-94d9-4d36-a494-682f7c89f535
parent 7b0e4e03
......@@ -95,7 +95,7 @@ void Core::slotObjectUpdated(int _identifier, UpdateType _type) {
}
}
// just inform the plugins as we dont do anything else (Do deprecated and new updatedObjects here
// just inform the plugins as we dont do anything else (Do deprecated and new updatedObjects here)
emit signalObjectUpdated(_identifier);
emit signalObjectUpdated(_identifier, _type);
......
......@@ -574,7 +574,7 @@ void Core::loadPlugin(QString filename, bool silent, QObject* _plugin){
if ( checkSlot( plugin , "slotObjectUpdated(int)" ) && checkSlot( plugin , "slotObjectUpdated(int,const UpdateType)" ) ){
log(LOGERR,tr("Plugin uses deprecated and(!) new slotObjectUpdated. Only new slotObjectUpdated will be active."));
connect(this,SIGNAL(signalObjectUpdated(int)),plugin,SLOT(slotObjectUpdated(int)), Qt::DirectConnection);
connect(this,SIGNAL(signalObjectUpdated(int,const UpdateType)),plugin,SLOT(slotObjectUpdated(int,const UpdateType)), Qt::DirectConnection);
} else {
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment