Commit 724a97fe authored by Mike Kremer's avatar Mike Kremer

PluginLoader now knows how to handle dylib plugins (Darwin support)

git-svn-id: http://www.openflipper.org/svnrepo/OpenFlipper/branches/Free@4727 383ad7c9-94d9-4d36-a494-682f7c89f535
parent 1d2ebabe
......@@ -207,10 +207,16 @@ static char *** argv_;
const bool is64 = false;
#endif
#ifdef WIN32
#if defined(WIN32)
const bool linux_ = false;
const bool windows_ = true;
const bool darwin_ = false;
#elif defined(ARCH_DARWIN)
const bool darwin_ = true;
const bool linux_ = false;
const bool windows_ = false;
#else
const bool darwin_ = false;
const bool linux_ = true;
const bool windows_ = false;
#endif
......@@ -226,6 +232,10 @@ bool isWindows() {
return windows_;
}
bool isDarwin() {
return darwin_;
}
QString lang() {
QString lang = getenv( "LANG" ) ;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment