Commit 65a8dbfe authored by Martin Schultz's avatar Martin Schultz

compatibility fixes for QOpenGLWidgets on Qt Version 5.4 and below

parent 7dd634fe
......@@ -52,7 +52,7 @@
#include <QtGlobal>
#if (QT_VERSION >= QT_VERSION_CHECK(5, 4, 0))
#if (QT_VERSION >= QT_VERSION_CHECK(5, 4, 4))
#include <QOpenGLWidget>
#include <QSurfaceFormat>
......
......@@ -514,7 +514,7 @@ glViewer::copyToImage( QImage& _image,
// makeCurrent();
#if (QT_VERSION >= QT_VERSION_CHECK(5, 4, 0))
#if (QT_VERSION >= QT_VERSION_CHECK(5, 4, 4))
_image = glWidget_->grabFramebuffer()
#else
_image = glWidget_->grabFrameBuffer(true)
......
......@@ -65,7 +65,7 @@
#include <OpenFlipper/common/GlobalOptions.hh>
#if (QT_VERSION >= QT_VERSION_CHECK(5,4,0))
#if (QT_VERSION >= QT_VERSION_CHECK(5,4,4))
#include <QOpenGLContext>
#endif
......@@ -80,7 +80,7 @@
void glViewer::swapBuffers() {
#if (QT_VERSION >= QT_VERSION_CHECK(5, 4, 0))
#if (QT_VERSION >= QT_VERSION_CHECK(5, 4, 4))
glWidget_->context()->swapBuffers(glWidget_->context()->surface());
#else
glWidget_->swapBuffers();
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment