Commit cb07a9a6 authored by Jan Möbius's avatar Jan Möbius

Updated qwt6 finder and max qt version warning

parent 42df1069
......@@ -79,7 +79,7 @@ if (NOT QT5_FOUND)
message(FATAL_ERROR "Could not found any QT Version. Please specify QT5_INSTALL_PATH (path to bin and include dir) to build with QT5")
endif()
set (OF_MAX_QT_VERSION "5.6.0")
set (OF_MAX_QT_VERSION "5.9.0")
if (${Qt5Core_VERSION_STRING} STRGREATER ${OF_MAX_QT_VERSION})
message(WARNING "Detected QT Version higher than ${OF_MAX_QT_VERSION}!\n" "OpenFlipper has not been tested with this QT Version.")
......
......@@ -28,10 +28,14 @@ elseif ( CMAKE_GENERATOR MATCHES "^Visual Studio 14.*" )
endif()
if (QT5_FOUND)
if (${Qt5Core_VERSION_STRING} VERSION_EQUAL "5.8.0" OR ${Qt5Core_VERSION_STRING} VERSION_GREATER "5.5.1")
if (${Qt5Core_VERSION_STRING} VERSION_EQUAL "5.9.0" )
SET(ACG_SEARCH_PATH "/ACG/acgdev/gcc-x86_64/qwt-6.1.3-qt5.9.0")
else()
if (${Qt5Core_VERSION_STRING} VERSION_EQUAL "5.8.0" OR ${Qt5Core_VERSION_STRING} VERSION_GREATER "5.5.1")
SET(ACG_SEARCH_PATH "/ACG/acgdev/gcc-x86_64/qwt-6.1.3-qt5.8.0")
else()
else()
SET(ACG_SEARCH_PATH "/ACG/acgdev/gcc-4.9-x86_64/qwt-6.1-qt5")
endif()
endif()
else()
SET(ACG_SEARCH_PATH "/usr/local/qwt/")
......@@ -110,13 +114,14 @@ if (QWT6_VERSION_FOUND)
)
# MACOS and LINUX
else()
find_library(QWT6_LIBRARY NAMES qwt-qt5
find_library(QWT6_LIBRARY NAMES qwt qwt-qt5
PATHS
"${ACG_SEARCH_PATH}/lib"
NO_DEFAULT_PATH
NO_CMAKE_PATH
NO_CMAKE_ENVIRONMENT_PATH
)
if (NOT QWT6_LIBRARY) # if not the specific acg qwt installation was found, try system wide
find_library(QWT6_LIBRARY NAMES qwt
PATHS
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment