Commit 6a083ce3 authored by Mike Kremer's avatar Mike Kremer

Set USE_OPENMP flag only if gcc is of version 4.3 and higher

git-svn-id: http://www.openflipper.org/svnrepo/OpenFlipper/branches/Free@4712 383ad7c9-94d9-4d36-a494-682f7c89f535
parent 593f2c06
......@@ -47,6 +47,15 @@
#define GLOBALDEFINES_HH
/**
* Get GCC version and convert to MMmm where MM is the major
* and mm the minor release version.
* For example if GCC_VERSION == 4030, we consider gcc-4.3.
*/
#define GCC_VERSION (__GNUC__ * 1000 + __GNUC_MINOR__ * 10)
//== DEEFINES =================================================================
/** Force static casts for Properties in OpenMesh.
......@@ -54,9 +63,11 @@
*/
#define OM_FORCE_STATIC_CAST
/** Enable openmp where possible
/** Enable openmp where possible (for gcc version >= 4.3)
*/
#define USE_OPENMP
#if GCC_VERSION >= 4030
#define USE_OPENMP
#endif
#ifndef DLLEXPORT
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment