Commit 072e60f5 authored by Jan Möbius's avatar Jan Möbius

Marlin: Fixed saving not checking if plugin supports extension



git-svn-id: http://www.openflipper.org/svnrepo/OpenFlipper/branches/Free@9786 383ad7c9-94d9-4d36-a494-682f7c89f535
parent 090d3bc5
......@@ -60,8 +60,11 @@ bool Core::saveObject( int _id, QString _filename ) {
BaseObjectData* object;
PluginFunctions::getObject(_id,object);
QString file_extension = _filename;
file_extension.remove(0, file_extension.length()-4);
for (int i=0; i < (int)supportedTypes_.size(); i++) {
if ( supportedTypes_[i].type.contains(object->dataType())) {
if ( supportedTypes_[i].type.contains(object->dataType()) && supportedTypes_[i].saveFilters.contains(file_extension)) {
if ( OpenFlipper::Options::gui() ) {
coreWidget_->statusMessage( tr("Saving ") + _filename + " ...");
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment