Commit f32e8ec9 authored by Philip Trettner's avatar Philip Trettner

updated readme a bit

parent 86db89b0
......@@ -2,6 +2,11 @@
## Migration Guide
### to 1.0
* `typed-graphics` is now the required, internally used math library and `glm` is an optionally supported
* OpenGL 4.5+ is required
### to 0.9
* `glm` is an external dependency now (applications need to provide it themselves and make a target `glm` available)
......@@ -9,7 +14,12 @@
## Changes
### 0.9
### 1.0 (next version)
* Migration to C++17
* OpenGL 4.5+ is required
### 0.9 (current version)
* `glow::info()` now works with `glm` types again (and anything that either has `operator<<` or `to_string`)
* removed `fmt` and `snappy` dependencies
......
......@@ -2,22 +2,21 @@
## Requirements
* C++11
* C++17
* CMake 3.0+
* OpenGL 3.3+
* OpenGL 4.5+
## Dependencies
Most dependencies are configurable and can be replaced by own versions.
* GLM (math, requires `GLM_ENABLE_EXPERIMENTAL` and `GLM_FORCE_CTOR_INIT` to be defined)
* Glad (ogl loading)
* `glm` (math, requires `GLM_ENABLE_EXPERIMENTAL` and `GLM_FORCE_CTOR_INIT` to be defined)
## Features and Goals
* Modern CMake Usage
* Modern C++ (C++11)
* Modern OpenGL (3.3+)
* Modern C++ (C++17)
* Modern OpenGL (4.5+)
* OpenGL Object Binding via RAII
* Automatic location mapping negotiation
* Automatic texture unit assignment
......
# Roadmap
## Version 1.0
* Documentation
* Testing
* All breaking changes and functionality that is not 0.9 (due to time)
## Version 0.9
* Target: SS18
* Breaking changes
* Mandatory color space for textures
* Renamings of some core functions
* New functionality
## Version 0.8 (current)
\ No newline at end of file
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment